RFR: 8325252: C2 SuperWord: refactor the packset [v4]
Christian Hagedorn
chagedorn at openjdk.org
Wed Mar 27 09:14:36 UTC 2024
On Tue, 26 Mar 2024 15:39:43 GMT, Christian Hagedorn <chagedorn at openjdk.org> wrote:
>> Emanuel Peter has updated the pull request incrementally with one additional commit since the last revision:
>>
>> use left/right instead of s1/s2 in some obvious simple places
>
> src/hotspot/share/opto/superword.cpp line 1414:
>
>> 1412: Node* n = pack->at(i);
>> 1413: set_pack(n, nullptr);
>> 1414: }
>
> Should we have a `remove_pack()` method that performs this operation? Then you could also call that just below at L1446 as well.
An additional thought: Should we have a special "unmap_pack_for_node" method that then calls `set_pack(n, nullptr)`? It might improve the readability.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/18276#discussion_r1539524372
More information about the hotspot-compiler-dev
mailing list