RFR: 8325520: Vector loads with offsets incorrectly compiled [v12]
Damon Fenacci
dfenacci at openjdk.org
Wed May 22 14:43:25 UTC 2024
On Wed, 22 May 2024 07:52:40 GMT, Tobias Hartmann <thartmann at openjdk.org> wrote:
>> src/hotspot/share/opto/vectornode.hpp line 893:
>>
>>> 891: class LoadVectorGatherNode : public LoadVectorNode {
>>> 892: public:
>>> 893: enum { Offsets = 3 };
>>
>> Just wondering about the naming convention here because the corresponding constructor argument is called `indices`. Should that be consistent?
>
> Also, where is this used?
You're right, they are always called "indices" even in the Vector API documentation. I've renamed them: offsets -> indices.
I've also removed all unused enums (in `LoadVector...Node` classes).
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/18347#discussion_r1610123425
More information about the hotspot-compiler-dev
mailing list