RFR: 8338023: Support two vector selectFrom API [v7]
Jatin Bhateja
jbhateja at openjdk.org
Wed Sep 18 07:21:52 UTC 2024
On Fri, 13 Sep 2024 14:49:01 GMT, Emanuel Peter <epeter at openjdk.org> wrote:
>> src/jdk.incubator.vector/share/classes/jdk/incubator/vector/ByteVector.java line 544:
>>
>>> 542: byte[] vpayload1 = ((ByteVector)v1).vec();
>>> 543: byte[] vpayload2 = ((ByteVector)v2).vec();
>>> 544: byte[] vpayload3 = ((ByteVector)v3).vec();
>>
>> Is there a reason you are not using more descriptive names here instead of `vpayload1`?
>> I also wonder if the `selectFromHelper` should not be named more specifically: `selectFromTwoVector(s)Helper`?
>
> You only gave me a thumbs up and no change - but comment resolved. Is that intentional? Makes me feel like you are ignoring my comments, and that discourages me from reviewing in the future.
Routine was renamed as per you suggestion and first vector argument also appropriately renamed to wrappedIndex.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/20508#discussion_r1764527888
More information about the hotspot-compiler-dev
mailing list