RFR: 8339992: RISC-V: some minor improvements of base64_vector_decode_round

Fei Yang fyang at openjdk.org
Wed Sep 18 14:15:06 UTC 2024


On Wed, 18 Sep 2024 12:57:41 GMT, Hamlin Li <mli at openjdk.org> wrote:

> Hi,
> Can you help to review this simple improvement?
> Thanks.

src/hotspot/cpu/riscv/stubGenerator_riscv.cpp line 5361:

> 5359:     __ vmseq_vi(v0, outputV1, -1);
> 5360:     __ vfirst_m(failedIdx, v0);
> 5361:     Label NoFailure, FailureAt0Idx;

Nit: Maybe rename `FailureAt0Idx` to `FailureAtIdx0`?

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/21059#discussion_r1765140867


More information about the hotspot-compiler-dev mailing list