RFR: 8340398: [JVMCI] Unintuitive behavior of UseJVMCICompiler option [v2]
Doug Simon
dnsimon at openjdk.org
Mon Sep 23 07:39:37 UTC 2024
On Mon, 23 Sep 2024 07:21:32 GMT, Tomáš Zezula <duke at openjdk.org> wrote:
>> src/hotspot/share/jvmci/jvmci_globals.cpp line 82:
>>
>>> 80: CHECK_NOT_SET(LibJVMCICompilerThreadHidden, UseJVMCICompiler)
>>> 81:
>>> 82: if (EnableJVMCI) {
>>
>> This needs to be `EnableJVMCI || UseJVMCICompiler` (since deriving `EnableJVMCI` from `UseJVMCICompiler` is only done [below](https://github.com/openjdk/jdk/blob/ab06a878f888827026424530781f0af414a8a611/src/hotspot/share/jvmci/jvmci_globals.cpp#L96)).
>
> I see, `FLAG_SET_DEFAULT(EnableJVMCI, true)` on [line 99](https://github.com/openjdk/jdk/blob/78f576192e815f957db93f5f8cb3763a35474381/src/hotspot/share/jvmci/jvmci_globals.cpp#L99).
> Maybe moving this block
>
> if (!FLAG_IS_DEFAULT(EnableJVMCI) && !EnableJVMCI) {
> jio_fprintf(defaultStream::error_stream(),
> "Improperly specified VM option UseJVMCICompiler: EnableJVMCI cannot be disabled\n");
> return false;
> }
> FLAG_SET_DEFAULT(EnableJVMCI, true);
>
> in front of my change makes it more readable.
It's not obvious to me how that's clearer than just expanding the guard on line 82 to be `EnableJVMCI || UseJVMCICompiler`.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/21069#discussion_r1770895929
More information about the hotspot-compiler-dev
mailing list