RFR: 8341976: C2: use_mem_state != load->find_exact_control(load->in(0)) assert failure

Galder Zamarreño galder at openjdk.org
Thu Feb 6 11:33:14 UTC 2025


On Wed, 5 Feb 2025 15:37:23 GMT, Roland Westrelin <roland at openjdk.org> wrote:

> The `arraycopy` writes to a non escaping array so its `ArrayCopy` node
> is marked as having a narrow memory effect. One of the loads from the
> destination after the copy is transformed into a load from the source
> array (the rationale being that if there's no load from the
> destination of the copy, the `arraycopy` is not needed). The load from
> the source has the input memory state of the `ArrayCopy` as memory
> input. That load is then sunk out of the loop and its control is
> updated to be after the `ArrayCopy`. That's legal because the
> `ArrayCopy` only has a narrow memory effect and can't modify the
> source. The `ArrayCopy` can't be eliminated and is expanded. In the
> process, a `MemBar` that has a wide memory effect is added. The load
> from the source has control after the membar but memory state before
> and because the membar has a wide memory effect, the load is anti
> dependent on the membar: the graph is broken (the load can't be pinned
> after the membar and anti dependent on it).
> 
> In short, the problem is that the graph is transformed under the
> assumption that the `ArrayCopy` has a narrow effect but the
> `ArrayCopy` is expanded to a subgraph that has a wide memory
> effect. The fix I propose is to not insert a membar with a wide memory
> effect. We still need a membar when the destination is non escaping
> because the expanded `ArrayCopy`, if it writes to a tighly allocated
> array, writes to raw memory and not to the destination memory slice.

src/hotspot/share/opto/macroArrayCopy.cpp line 831:

> 829:     insert_mem_bar(ctrl, &out_mem, Op_MemBarStoreStore, Compile::AliasIdxBot);
> 830:   } else {
> 831:     int alias_idx = Compile::AliasIdxBot;

Minor thing, `alias_idx` is already defined in the method with a different type. Would it make sense to use a different name here?

Earlier definition:

uint alias_idx = C->get_alias_index(adr_type);

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/23465#discussion_r1944562243


More information about the hotspot-compiler-dev mailing list