RFR: 8345766: C2 should emit macro nodes for ModF/ModD instead of calls during parsing

Emanuel Peter epeter at openjdk.org
Wed Jan 8 08:25:49 UTC 2025


On Tue, 7 Jan 2025 16:54:46 GMT, Vladimir Kozlov <kvn at openjdk.org> wrote:

>> C2 currently emits runtime calls if the platform rules do not support lowering floating point remainder operations. For example, for float:
>> 
>> https://github.com/openjdk/jdk/blob/fbbc7c35f422294090b8c7a02a19ab2fb67c7070/src/hotspot/share/opto/parse2.cpp#L2305-L2318
>> 
>> https://github.com/openjdk/jdk/blob/fbbc7c35f422294090b8c7a02a19ab2fb67c7070/src/hotspot/share/opto/parse2.cpp#L1099-L1109
>> 
>> The only platform, which currently supports this, however, is x86_32. On all other platforms, runtime calls are generated directly during parsing, which prevent any constant folding or other idealizations. Even C1 can perform these optimizations, resulting in significantly lower C2 performance compared to C1 for simple test cases. This function was observed to be around 15x slower with C2 compared to C1 due to redundant runtime calls:
>> 
>> 
>> public static double process(final double x) {
>>         double w = (double) 0.1;
>>         double p = 0;
>>         p = (double) (3.109615012413746E307 % (w % Z));
>>         p = (double) (7.614949555185036E307 / (x % x)); // <- return value only dependends on this line
>>         return (double) (x * p);
>> }
>> 
>> 
>> To fix this, this PR turns ModFNode and ModDNode into macros, which are always created during parsing. They support idealization (constant folding) and are lowered to runtime calls during macro expansion. For simplicity, these operations will now also call into the runtime on x86_32, as this platform is deprecated.
>
> src/hotspot/share/opto/callnode.cpp line 721:
> 
>> 719: const Type *CallNode::bottom_type() const { return tf()->range(); }
>> 720: const Type* CallNode::Value(PhaseGVN* phase) const {
>> 721:   if (!in(0) || phase->type(in(0)) == Type::TOP) {
> 
> We use explicit compare `in(0) == nullptr`.

Suggestion:

  if (in(0) == nullptr || phase->type(in(0)) == Type::TOP) {


`Do not use ints or pointers as (implicit) booleans with &&, ||, if, while. Instead, compare explicitly, i.e. if (x != 0) or if (ptr != nullptr), etc.`

See
https://github.com/openjdk/jdk/blob/master/doc/hotspot-style.md

> src/hotspot/share/opto/parse2.cpp line 1100:
> 
>> 1098: 
>> 1099: Node* Parse::floating_point_mod(Node* a, Node* b, bool dbl) {
>> 1100:   CallNode* mod = dbl ? static_cast<CallNode*>(new ModDNode(C, a, b)) : new ModFNode(C, a, b);
> 
> Why you need the case for `ModDNode`?

He has a call from `Bytecodes::_frem:` and from `Bytecodes::_drem:`.

Why not make it a `BasicType bt` instead of `dbl`, and then switch on that? Might be more readable than true / false.
I read `floating_point_mod(a, b, true)`, and am not sure what the `true` does.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/22786#discussion_r1906654174
PR Review Comment: https://git.openjdk.org/jdk/pull/22786#discussion_r1906709210


More information about the hotspot-compiler-dev mailing list