RFR: 8348411: C2: Remove the control input of LoadKlassNode and LoadNKlassNode [v2]

Vladimir Ivanov vlivanov at openjdk.org
Thu Jan 30 16:41:59 UTC 2025


On Thu, 30 Jan 2025 07:53:33 GMT, Quan Anh Mai <qamai at openjdk.org> wrote:

>> src/hotspot/share/opto/parseHelper.cpp line 168:
>> 
>>> 166:   // succeeds.
>>> 167:   if (MonomorphicArrayCheck && !too_many_traps(Deoptimization::Reason_array_check) && !tak->klass_is_exact()
>>> 168:       && tak != TypeInstKlassPtr::OBJECT) {
>> 
>> I'd also turn `tak != TypeInstKlassPtr::OBJECT` into `tak->isa_aryklassptr()` to stress the intention.
>> (Please, keep the original formatting here.)
>
> Done, I assume you meant the formatting of the comment below, right?

No, I referred to the original shape of the condition (1 check per line). IMO it is easier to follow.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/23274#discussion_r1935926644


More information about the hotspot-compiler-dev mailing list