RFR: 8351348: x86_64: remove redundant supports_float16 check
Hamlin Li
mli at openjdk.org
Fri Mar 7 09:56:52 UTC 2025
On Thu, 6 Mar 2025 13:18:07 GMT, Hamlin Li <mli at openjdk.org> wrote:
> Hi,
> Can you help to review this simple patch?
> `supports_float16()` is invoked in `is_intrinsic_available -> is_intrinsic_supported`, so there is no need to call it explicitly.
>
> Thanks
Thanks for having a look!
>From code readability sense, seems it's worth, as check of `supports_float16` is already part of check in `vmIntrinsics::is_intrinsic_available` and the names should already implies this.
But you're right too, in performance sense, it's not worth to do so. On the other hand, the code is not in performance critical path.
How do you think about it?
-------------
PR Comment: https://git.openjdk.org/jdk/pull/23932#issuecomment-2706013532
More information about the hotspot-compiler-dev
mailing list