RFR: 8351876: RISC-V: enable and fix some float round tests

Fei Yang fyang at openjdk.org
Thu Mar 13 08:44:52 UTC 2025


On Thu, 13 Mar 2025 08:31:15 GMT, Hamlin Li <mli at openjdk.org> wrote:

>> test/hotspot/jtreg/compiler/vectorization/TestRoundVectFloat.java line 56:
>> 
>>> 54:       counts = {IRNode.ROUND_VF , " > 0 "})
>>> 55:   @IR(applyIfPlatform = {"riscv64", "true"},
>>> 56:       applyIfCPUFeature = {"rvv", "true"},
>> 
>> This `applyIfCPUFeature = {"rvv", "true"},` seems unnecessary? You have already requires `(os.simpleArch == "riscv64" & vm.cpu.features ~= ".*rvv.*")` for this test.
>
> Yes, it's unnecessary.
> But we require `MaxVectorSize >= 32` below, so maybe it's better to keep it for readability.

I guess it's not a big issue. I just find it's not the case when looking at changes made in this file : test/hotspot/jtreg/compiler/vectorization/TestRoundVectRiscv64.java

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/24015#discussion_r1993028605


More information about the hotspot-compiler-dev mailing list