6348631 - request for review

Ivan Krylov Ivan.Krylov at Oracle.COM
Sun Nov 21 14:32:22 PST 2010


Hi Dmitry,

On 19.11.2010 22:30, Dmitry Samersoff wrote:
> On 2010-11-19 13:19, Ivan Krylov wrote:
>> David, Volker,
>>
>> Thanks for your feedbacks. My comments are inlined.
>> Here is a new webrev with suggested changes
>> http://cr.openjdk.java.net/~ikrylov/6348631.v2/
>
> src/os/linux/vm/os_linux.cpp:1526
>
> +        buf[n] = '\0';
> wrong indent
ok
>
> -""-:4261
>
> +  fd = open64(path, oflag, mode);
>
> Should be ::open64
That is not necessary
>
> src/os/linux/vm/os_linux.inline.hpp:187
>
> +  return send(fd, buf, nBytes, flags);
>
> Should be ::send
My code is correct. See original hpi code. it was calling hpi::send before.

>
> src/os/solaris/vm/os_solaris.cpp:1717
>
> In bool os::vtime_enabled()
>
> We should use ::open, ::close but os::read here. I guess it should be either os::* or ::*
I don't see anything wrong here. I am doing exactly what this code was doing before.

>
> src/os/windows/vm/os_windows.inline.hpp:88
>
> +  return send(fd, buf, nBytes, flags);
>
> Should be ::send
No, it should either call os:send or    ShouldNotReachHere();
But yes, I will move it to where other windows socket functions are.



>
> -Dmitry
>
>
> PS:
> I support Volker's claim to rename hpi_read to restartable_read

It was renamed to hpi_read per Karen's request. I will not change it back.

Thanks,
Ivan




More information about the hotspot-dev mailing list