6348631 - request for review
Dmitry Samersoff
Dmitry.Samersoff at oracle.com
Fri Nov 19 11:30:35 PST 2010
On 2010-11-19 13:19, Ivan Krylov wrote:
> David, Volker,
>
> Thanks for your feedbacks. My comments are inlined.
> Here is a new webrev with suggested changes
> http://cr.openjdk.java.net/~ikrylov/6348631.v2/
src/os/linux/vm/os_linux.cpp:1526
+ buf[n] = '\0';
wrong indent
-""-:4261
+ fd = open64(path, oflag, mode);
Should be ::open64
src/os/linux/vm/os_linux.inline.hpp:187
+ return send(fd, buf, nBytes, flags);
Should be ::send
src/os/solaris/vm/os_solaris.cpp:1717
In bool os::vtime_enabled()
We should use ::open, ::close but os::read here. I guess it should be
either os::* or ::*
src/os/windows/vm/os_windows.inline.hpp:88
+ return send(fd, buf, nBytes, flags);
Should be ::send
-Dmitry
PS:
I support Volker's claim to rename hpi_read to restartable_read
--
Dmitry Samersoff
J2SE Sustaining team, SPB04
* Give Rabbit time and he'll always get the answer ...
More information about the hotspot-dev
mailing list