RFR(s): 8211403: Rename SafepointMechanism::poll(...)
Robbin Ehn
robbin.ehn at oracle.com
Wed Nov 7 11:37:09 UTC 2018
Hi David,
> Except there's a level in between that. If poll() should be should_block() then
> global_poll() should be global_should_block() and local_poll() should be
> local_should_block(). I don't see any difference. It's the methods under that
> that actually "poll" something.
The difference is private vs public.
I'm fixing the issue that some raised about this:
if (SafepointMechanism::poll(Self)) return 0;
Not being clear as:
if (SafepointMechanism::should_block(Self)) return 0;
The implementation is fine by me, I do not consider changes there my goal at all.
Thanks, Robbin
>
> David
>
>>
>> Thanks, Robbin
>>
>>>
>>> Thanks,
>>> David
>>>
>>>>
>>>> CR: https://bugs.openjdk.java.net/browse/JDK-8211403
>>>> Webrev: http://cr.openjdk.java.net/~rehn/8211403/webrev/
>>>>
>>>> Sanity on tier 1.
>>>>
>>>> Thanks, Robbin
More information about the hotspot-dev
mailing list