RFR(s): 8211403: Rename SafepointMechanism::poll(...)
Daniel D. Daugherty
daniel.daugherty at oracle.com
Wed Nov 7 17:33:24 UTC 2018
On 11/7/18 3:32 AM, Robbin Ehn wrote:
> Hi all, please review.
>
> We rename SafepointMechanism::poll to SafepointMechanism::should_block
> to make
> it more clear what the method do.
>
> CR: https://bugs.openjdk.java.net/browse/JDK-8211403
> Webrev: http://cr.openjdk.java.net/~rehn/8211403/webrev/
src/hotspot/cpu/zero/cppInterpreter_zero.cpp
src/hotspot/share/jvmci/jvmciCodeInstaller.cpp
src/hotspot/share/runtime/interfaceSupport.inline.hpp
src/hotspot/share/runtime/mutex.cpp
src/hotspot/share/runtime/objectMonitor.cpp
No comments on the above files.
src/hotspot/share/runtime/safepointMechanism.hpp
Needs a copyright year update.
L76: // Call this method to see if this thread has depending poll
and appropriate action should be taken
L77: static inline bool should_block(Thread* thread);
The comment needs to be changed. Perhaps:
// Call this method to see if this thread should block for a
safepoint.
src/hotspot/share/runtime/safepointMechanism.inline.hpp
Needs a copyright year update.
src/hotspot/share/runtime/sweeper.cpp
No comments.
Thumbs up! Your call on whether to apply the renaming to
global_poll() and local_poll(). I understand both points
of view and I don't have a preference...
Dan
>
> Sanity on tier 1.
>
> Thanks, Robbin
>
More information about the hotspot-dev
mailing list