RFR: JDK-8256922: ppc, ppcle build broken after JDK-8254231 [v2]
Aleksey Shipilev
shade at openjdk.java.net
Tue Nov 24 07:45:01 UTC 2020
On Tue, 24 Nov 2020 07:30:20 GMT, Thomas Stuefe <stuefe at openjdk.org> wrote:
>> Hi,
>>
>> may I please have reviews for these fixes to the ppc, ppcle builds after JDK-8254231.
>>
>> Once the build is fixed, VM does not come up, but that is a separate issue (JDK-8256924).
>>
>> This roughly followed Alekseys work on s390, but additionally I had to rename the _abi macro due to name conflict with a class member in the new code.
>>
>> Thanks, Thomas
>
> Thomas Stuefe has updated the pull request incrementally with two additional commits since the last revision:
>
> - include guard misnamed
> - Rename files
A few minor nits.
src/hotspot/cpu/ppc/foreign_globals_ppc.cpp line 39:
> 37: return {};
> 38: }
> 39:
Excess empty line.
src/hotspot/cpu/ppc/foreign_globals_ppc.hpp line 31:
> 29: class ABIDescriptor {};
> 30:
> 31:
Excess double line.
src/hotspot/cpu/ppc/sharedRuntime_ppc.cpp line 3441:
> 3439: return nullptr;
> 3440: }
> 3441:
Excess new line.
src/hotspot/cpu/ppc/frame_ppc.hpp line 121:
> 119: };
> 120:
> 121: #define _abi0(_component) \
When I was experimenting with this code, I thought to name it consistently with `_abi_reg_args_spill` definition a few lines below. That is, make it `_abi_reg_args`. Does that make more sense than `_abi0`?
-------------
Changes requested by shade (Reviewer).
PR: https://git.openjdk.java.net/jdk/pull/1404
More information about the hotspot-dev
mailing list