RFR: 8213269: convert test/hotspot/jtreg/runtime/memory/RunUnitTestsConcurrently to gtest [v6]
Mikhailo Seledtsov
mseledtsov at openjdk.java.net
Wed Mar 3 20:15:41 UTC 2021
On Wed, 3 Mar 2021 20:10:00 GMT, Mikhailo Seledtsov <mseledtsov at openjdk.org> wrote:
>> Hi Thomas,
>>
>>> <... >Just wanted to understand the direction you guys plan to go with gtests in the future. If they get more complex and powerful we may need more control, eg the possibility to problemlist tests. <...>
>>
>> as you have discovered yourself, gtest already has support for the temporary exclusion of tests. I agree that it inferior to problemlists and I'd like to let you know that there is a plan to make it possible to use a problemlist-like solution to exclude gtests. however, it's not on the top of my to-do list as **currently** there is no big need for that. should it change I'll reprioritize that work.
>>
>> -- Igor
>
> On question: "Would it be possible to rename the gtests to make them start with "os"? "
> OK. I can rename reserve_space_concurrent to os_reserve_space_concurrent and virtual_space_concurrent to os_virtual_space_concurrent, if I do not hear any objections.
Thank you to all the participants for your feedback, discussion and comments.
To summarize I will make the following changes:
- rename concurrent_test_runner.inline.hpp to concurrentTestRunner.inline.hpp
- replace use of std::vector by os:malloced array
- include all the necessary includes into concurrentTestRunner.inline.hpp so it is self-sufficient
- remove "virtual ~ConcurrentTestRunner() {}"
- rename reserve_space_concurrent to os_reserve_space_concurrent and virtual_space_concurrent to os_virtual_space_concurrent
-------------
PR: https://git.openjdk.java.net/jdk/pull/2436
More information about the hotspot-dev
mailing list