RFR: 8264126: Remove TRAPS/THREAD parameter for class loading functions [v2]

David Holmes dholmes at openjdk.java.net
Thu Mar 25 04:16:48 UTC 2021


On Wed, 24 Mar 2021 20:37:35 GMT, Ioi Lam <iklam at openjdk.org> wrote:

>> Coleen Phillimore has updated the pull request incrementally with one additional commit since the last revision:
>> 
>>   Improvements suggested by Ioi.
>
> src/hotspot/share/classfile/systemDictionaryShared.cpp line 1873:
> 
>> 1871:   } else {
>> 1872:     assert(!Thread::current()->is_VM_thread(), "must not be");
>> 1873:     Arguments::assert_is_dumping_archive();
> 
> The code  after the assert should always be executed, not predicated on DynamicDumpSharedSpaces.

I'm finding the logic change here very hard to follow. Being in the VMThread may imply that DynamicDumpSharedSpaces must be true, but that doesn't necessarily mean that if not in the VMThread then DynamicDumpSharedSpaces must be false.

-------------

PR: https://git.openjdk.java.net/jdk/pull/3176


More information about the hotspot-dev mailing list