RFR: 8264126: Remove TRAPS/THREAD parameter for class loading functions [v2]
Coleen Phillimore
coleenp at openjdk.java.net
Thu Mar 25 13:06:00 UTC 2021
On Thu, 25 Mar 2021 04:11:36 GMT, David Holmes <dholmes at openjdk.org> wrote:
>> src/hotspot/share/classfile/systemDictionaryShared.cpp line 1873:
>>
>>> 1871: } else {
>>> 1872: assert(!Thread::current()->is_VM_thread(), "must not be");
>>> 1873: Arguments::assert_is_dumping_archive();
>>
>> The code after the assert should always be executed, not predicated on DynamicDumpSharedSpaces.
>
> I'm finding the logic change here very hard to follow. Being in the VMThread may imply that DynamicDumpSharedSpaces must be true, but that doesn't necessarily mean that if not in the VMThread then DynamicDumpSharedSpaces must be false.
I got this logic wrong, now fixed.
-------------
PR: https://git.openjdk.java.net/jdk/pull/3176
More information about the hotspot-dev
mailing list