RFR: 8277372: Add getters for BOT and card table members [v2]
Vishal Chand
duke at openjdk.java.net
Mon Nov 29 13:02:09 UTC 2021
On Mon, 29 Nov 2021 09:41:54 GMT, Thomas Schatzl <tschatzl at openjdk.org> wrote:
>> Vishal Chand has updated the pull request incrementally with one additional commit since the last revision:
>>
>> Refactoring in hotspot/cpu dir
>
> src/hotspot/share/gc/shared/blockOffsetTable.hpp line 56:
>
>> 54: static uint _LogN_words;
>> 55: static uint _N_bytes;
>> 56: static uint _N_words;
>
> The `private` visibility modifier can be removed as this is default at the top of a class.
> The static variables should start with a lower case letter after the underscore, something like `_log_n`.
>
> My suggestion would also be to change `N`/`n` to something more understandable, like `size`, and add `block`, i.e. something like `_log_block_size`, `_log_block_size_in_words` similar to the corresponding `CardTable` members etc.
>
> Edit: note that "block" isn't a good word to use here, so scratch that - "block" is any kind of area that is more generic than an object, but does not refer to the BOT entry.
As I can understand, we need to replace "N" with something meaningful. Does something like "entry_size" or "bot_entry_size" would work?
-------------
PR: https://git.openjdk.java.net/jdk/pull/6570
More information about the hotspot-dev
mailing list