RFR: 8287661: Fix and improve BitMap::print_on(outputStream*)
Stefan Karlsson
stefank at openjdk.java.net
Wed Jun 1 15:49:45 UTC 2022
On Wed, 1 Jun 2022 10:04:05 GMT, Aleksey Shipilev <shade at openjdk.org> wrote:
> Found these inconvenient during debugging using the `BitMap::print_on`. We pass the `outputStream*` to the method, but do not use it. Also, the output is hard to read for large bitmaps.
>
> Sample output generated by gtest:
>
>
> Bitmap (0 bits):
> Bitmap (128 bits):
> 0: .......... .......... .......... .......... ..........
> 50: .......... ....S..... .......... .......... ..........
> 100: .......... .......... ........
> Bitmap (1024 bits):
> 0: .......... .......... .......... .......... ..........
> 50: .......... .......... .......... .......... ..........
> 100: .......... .......... .......... .......... ..........
> 150: .......... .......... .......... .......... ..........
> 200: .......... .......... .......... .......... ..........
> 250: .......... .......... .......... .......... ..........
> 300: .......... .......... .......... .......... ..........
> 350: .......... .......... .......... .......... ..........
> 400: .......... .......... .......... .......... ..........
> 450: .......... .......... .......... .......... ..........
> 500: .......... ..S....... .......... .......... ..........
> 550: .......... .......... .......... .......... ..........
> 600: .......... .......... .......... .......... ..........
> 650: .......... .......... .......... .......... ..........
> 700: .......... .......... .......... .......... ..........
> 750: .......... .......... .......... .......... ..........
> 800: .......... .......... .......... .......... ..........
> 850: .......... .......... .......... .......... ..........
> 900: .......... .......... .......... .......... ..........
> 950: .......... .......... .......... .......... ..........
> 1000: .......... .......... ....
>
>
> It becomes clearer that bits 64 and 512 are set, respectively.
>
> Additional testing:
> - [x] Linux x86_64 fastdebug, new gtest
> - [x] Linux x86_64 release, new gtest
Great that you found this!
src/hotspot/share/utilities/bitMap.cpp line 706:
> 704: }
> 705: st->cr();
> 706: }
I wonder if it wouldn't be more useful to use line and chunk sizes that are a power-of-two? Maybe if we find that that would be more useful, than we could later add a second function to support that.
test/hotspot/gtest/utilities/test_bitMap.cpp line 107:
> 105: map.set_bit(size / 2);
> 106: }
> 107: map.print_on(tty);
I would prefer if we didn't print to tty here. I think we should try to stay away from printing out stuff in the gtest runs. (I know that some of the tests do it).
This can be easily fixed by printing to UL:
diff --git a/test/hotspot/gtest/utilities/test_bitMap.cpp b/test/hotspot/gtest/utilities/test_bitMap.cpp
index 7391d21ccc2..80404907e90 100644
--- a/test/hotspot/gtest/utilities/test_bitMap.cpp
+++ b/test/hotspot/gtest/utilities/test_bitMap.cpp
@@ -22,6 +22,7 @@
*/
#include "precompiled.hpp"
+#include "logging/logStream.hpp"
#include "memory/resourceArea.hpp"
#include "utilities/bitMap.inline.hpp"
#include "unittest.hpp"
@@ -104,7 +105,9 @@ class BitMapTest {
if (size > 0) {
map.set_bit(size / 2);
}
- map.print_on(tty);
+
+ LogStreamHandle(Info, test) stream;
+ map.print_on(&stream);
}
#endif
And if you want to see the output you can then just run with:
make test exploded-test-gtest GTEST="JAVA_OPTIONS=-Xlog:test;OPTIONS=--gtest_filter=BitMap*"
-------------
Changes requested by stefank (Reviewer).
PR: https://git.openjdk.java.net/jdk/pull/8970
More information about the hotspot-dev
mailing list