RFR: 8287661: Fix and improve BitMap::print_on(outputStream*)

Aleksey Shipilev shade at openjdk.java.net
Wed Jun 1 15:49:46 UTC 2022


On Wed, 1 Jun 2022 15:05:41 GMT, Stefan Karlsson <stefank at openjdk.org> wrote:

>> Found these inconvenient during debugging using the `BitMap::print_on`. We pass the `outputStream*` to the method, but do not use it. Also, the output is hard to read for large bitmaps. 
>> 
>> Sample output generated by gtest:
>> 
>> 
>> Bitmap (0 bits):
>> Bitmap (128 bits):
>>     0: .......... .......... .......... .......... ..........
>>    50: .......... ....S..... .......... .......... ..........
>>   100: .......... .......... ........
>> Bitmap (1024 bits):
>>     0: .......... .......... .......... .......... ..........
>>    50: .......... .......... .......... .......... ..........
>>   100: .......... .......... .......... .......... ..........
>>   150: .......... .......... .......... .......... ..........
>>   200: .......... .......... .......... .......... ..........
>>   250: .......... .......... .......... .......... ..........
>>   300: .......... .......... .......... .......... ..........
>>   350: .......... .......... .......... .......... ..........
>>   400: .......... .......... .......... .......... ..........
>>   450: .......... .......... .......... .......... ..........
>>   500: .......... ..S....... .......... .......... ..........
>>   550: .......... .......... .......... .......... ..........
>>   600: .......... .......... .......... .......... ..........
>>   650: .......... .......... .......... .......... ..........
>>   700: .......... .......... .......... .......... ..........
>>   750: .......... .......... .......... .......... ..........
>>   800: .......... .......... .......... .......... ..........
>>   850: .......... .......... .......... .......... ..........
>>   900: .......... .......... .......... .......... ..........
>>   950: .......... .......... .......... .......... ..........
>>  1000: .......... .......... ....
>> 
>> 
>> It becomes clearer that bits 64 and 512 are set, respectively.
>> 
>> Additional testing:
>>  - [x] Linux x86_64 fastdebug, new gtest
>>  - [x] Linux x86_64 release, new gtest
>
> src/hotspot/share/utilities/bitMap.cpp line 706:
> 
>> 704:   }
>> 705:   st->cr();
>> 706: }
> 
> I wonder if it wouldn't be more useful to use line and chunk sizes that are a power-of-two? Maybe if we find that that would be more useful, than we could later add a second function to support that.

My thought was that the *humans* would try to see where the set bits are, and so working in decimals is better? But we can do binary too, maybe grouping by 8 bits and 8 bytes per line would be quite natural.

-------------

PR: https://git.openjdk.java.net/jdk/pull/8970


More information about the hotspot-dev mailing list