RFR: 8288623: Move Continuation classes out of javaClasses.hpp [v2]

Stefan Karlsson stefank at openjdk.org
Fri Jun 17 08:40:51 UTC 2022


On Thu, 16 Jun 2022 22:23:51 GMT, Ioi Lam <iklam at openjdk.org> wrote:

>> javaClasses.hpp is getting too big - it contains the C++ representation of over 50 Java classes.
>> 
>> The RFE moves the following classes into a new file, continuationJavaClasses.hpp. The naming follows the same pattern as the existing header share/jvmci/jvmciJavaClasses.hpp.
>> 
>> - jdk_internal_vm_ContinuationScope
>> - jdk_internal_vm_Continuation
>> - jdk_internal_vm_StackChunk
>
> Ioi Lam has updated the pull request incrementally with one additional commit since the last revision:
> 
>   added missing includes that were hidden by previously unnedded includes

If we are about to start to squirrel away parts of javaClasses into new files, I wonder if the discoverability of these functions will be better if we use this naming instead:

javaClasses.hpp
javaClassesContinuation.hpp
javaClassesInvoke.hpp
...

instead of:

javaClasses.hpp
continuationJavaClasses.hpp
invokeJavaClasses.hpp
...

src/hotspot/share/classfile/continuationJavaClasses.inline.hpp line 26:

> 24: 
> 25: #ifndef SHARE_CLASSFILE_JDK_INTERNAL_VM_STACKCHUNK_INLINE_HPP
> 26: #define SHARE_CLASSFILE_JDK_INTERNAL_VM_STACKCHUNK_INLINE_HPP

This include guard doesn't follow the current naming convention.

-------------

PR: https://git.openjdk.org/jdk/pull/9191


More information about the hotspot-dev mailing list