RFR: 8288623: Move Continuation classes out of javaClasses.hpp [v2]
Ioi Lam
iklam at openjdk.org
Fri Jun 17 15:27:02 UTC 2022
On Fri, 17 Jun 2022 08:37:22 GMT, Stefan Karlsson <stefank at openjdk.org> wrote:
> If we are about to start to squirrel away parts of javaClasses into new files, I wonder if the discoverability of these functions will be better if we use this naming instead:
>
> ```
> javaClasses.hpp
> javaClassesContinuation.hpp
> javaClassesInvoke.hpp
> ...
> ```
>
> instead of:
>
> ```
> javaClasses.hpp
> continuationJavaClasses.hpp
> invokeJavaClasses.hpp
> ...
> ```
I am not in love with either naming convention (the names are too long), but the latter sounds more grammatically correct. Also, as Coleen mentioned, if we choose the former, we need to rename jvmciJavaClasses.hpp as well.
The former can be discovered as `javaClasses*` and the latter as `*avaClasses*`, so there's not much difference.
-------------
PR: https://git.openjdk.org/jdk/pull/9191
More information about the hotspot-dev
mailing list