RFR: 8294430: riscv: small refactoring for movptr_with_offset
Fei Yang
fyang at openjdk.org
Tue Sep 27 07:28:32 UTC 2022
The name of function 'movptr_with_offset' looks misleading. It actually returns an offset to its caller.
We could rename this function to 'movptr' so that it overloads existing function 'movptr'.
void movptr(Register Rd, address addr);
- void movptr_with_offset(Register Rd, address addr, int32_t &offset);
+ void movptr(Register Rd, address addr, int32_t &offset);
Testing: Tier1 hotspot tested on HiFive Unmatched board.
-------------
Commit messages:
- 8294430: riscv: small refactoring for movptr_with_offset
Changes: https://git.openjdk.org/jdk/pull/10439/files
Webrev: https://webrevs.openjdk.org/?repo=jdk&pr=10439&range=00
Issue: https://bugs.openjdk.org/browse/JDK-8294430
Stats: 28 lines in 10 files changed: 0 ins; 2 del; 26 mod
Patch: https://git.openjdk.org/jdk/pull/10439.diff
Fetch: git fetch https://git.openjdk.org/jdk pull/10439/head:pull/10439
PR: https://git.openjdk.org/jdk/pull/10439
More information about the hotspot-dev
mailing list