RFR: 8294430: RISC-V: Small refactoring for movptr_with_offset
Feilong Jiang
fjiang at openjdk.org
Tue Sep 27 08:18:43 UTC 2022
On Tue, 27 Sep 2022 07:20:11 GMT, Fei Yang <fyang at openjdk.org> wrote:
> The name of function 'movptr_with_offset' looks misleading. It actually returns an offset to its caller.
> We could rename this function to 'movptr' so that it overloads existing function 'movptr'.
>
>
> void movptr(Register Rd, address addr);
> - void movptr_with_offset(Register Rd, address addr, int32_t &offset);
> + void movptr(Register Rd, address addr, int32_t &offset);
>
>
> Testing: Tier1 hotspot on HiFive Linux-riscv64 Unmatched board.
Looks fine, thanks!
-------------
Marked as reviewed by fjiang (Author).
PR: https://git.openjdk.org/jdk/pull/10439
More information about the hotspot-dev
mailing list