RFR: 8231349: Move intrinsic stubs generation to compiler runtime initialization code [v2]
Vladimir Ivanov
vlivanov at openjdk.org
Wed Mar 22 23:07:42 UTC 2023
On Wed, 22 Mar 2023 22:35:00 GMT, Vladimir Kozlov <kvn at openjdk.org> wrote:
>> src/hotspot/cpu/aarch64/globals_aarch64.hpp line 39:
>>
>>> 37: define_pd_global(bool, UncommonNullCast, true); // Uncommon-trap NULLs past to check cast
>>> 38:
>>> 39: #if COMPILER2_OR_JVMCI
>>
>> I find it easier to read when only the default value is guarded. In that respect, `COMPILER2_OR_JVMCI` code diverges from the rest of the code base.
>
> So you want something similar to `COMPILER1_AND_COMPILER2_PRESENT()` used for `CodeCacheSegmentSize` in following line?
> Yes, we have similar macro for JVMCI and C2. How about this:
>
> define_pd_global(bool, MoveIntrinsicStubsGen, false COMPILER2_OR_JVMCI_PRESENT( || true));
What about the following?
define_pd_global(bool, MoveIntrinsicStubsGen, NOT_COMPILER2_OR_JVMCI(false) COMPILER2_OR_JVMCI_PRESENT(true));
Are you concerned it is too long?
Or even `NOT_COMPILER2_OR_JVMCI` maybe?
define_pd_global(bool, MoveIntrinsicStubsGen, COMPILER2_OR_JVMCI);
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/13096#discussion_r1145494445
More information about the hotspot-dev
mailing list