RFR: 8301997: Move method resolution information out of the cpCache

Matias Saavedra Silva matsaave at openjdk.org
Tue Oct 17 16:52:57 UTC 2023


On Tue, 17 Oct 2023 11:07:35 GMT, Andrew Dinn <adinn at openjdk.org> wrote:

>> The current structure used to store the resolution information for methods, ConstantPoolCacheEntry, is difficult to interpret due to its ambigious fields f1 and f2. This structure previously held information for fields, methods, and invokedynamic calls which were all encoded into f1 and f2. Currently this structure only handles method entries, but it remains obtuse and inconsistent with recent changes. 
>> 
>> This enhancement introduces a new data structure that stores the necessary resolution data in an intuitive an extensible manner. These resolved entries are stored in an array inside the constant pool cache in a very similar manner to invokedynamic entries in JDK-8301995.
>> 
>> Instances of ConstantPoolCache entry related to field resolution have been replaced with the new ResolvedMethodEntry, and ConstantPoolCacheEntry has been removed entirely. The class ResolvedMethodEntry holds resolution information for all types of invoke calls besides invokedynamic, and thus has fields that may be unused depending on the invoke code. 
>> 
>> To streamline the review, please consider these major areas that have been changed:
>> 1. ResolvedMethodEntry class
>> 2. Rewriter for initialization of the structure
>> 3. cpCache for resolution
>> 4. InterpreterRuntime, linkResolver, and templateTable
>> 5. JVMCI
>> 6. SA
>> 
>> Verified with tier 1-9 tests.
>> 
>> This change supports the following platforms: x86, aarch64
>
> src/hotspot/cpu/aarch64/templateTable_aarch64.cpp line 2369:
> 
>> 2367: }
>> 2368: 
>> 2369: void TemplateTable::load_resolved_method_entry_common(Register cache,
> 
> When I saw the `common` suffix I thought at first that this might be used in addition to the variants with the other suffixes rather than as an alternative. Since this is 'common' to only to 2 out of the 5 different cases perhaps it could be named `load_resolved_method_entry_special_or_static`. That would make it clear that each invoke type has a corresponding `load_resolved_method_entry_<invoketype>` variant.

I struggled with naming this method which is why I settled on `common` but you are correct that it gives the wrong impression. However, I think `load_resolved_method_entry_special_or_static` is too verbose (44 characters!). Do you think there is a better name or is our best option to use this longer one?

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/15455#discussion_r1362465873


More information about the hotspot-dev mailing list