RFR: 8319801: Recursive lightweight locking: aarch64 implementation [v6]
Axel Boldt-Christmas
aboldtch at openjdk.org
Wed Jan 24 14:15:00 UTC 2024
On Wed, 24 Jan 2024 11:27:25 GMT, Roman Kennke <rkennke at openjdk.org> wrote:
>> Axel Boldt-Christmas has updated the pull request with a new target base due to a merge or a rebase. The incremental webrev excludes the unrelated changes brought in by the merge/rebase. The pull request contains 10 additional commits since the last revision:
>>
>> - Merge remote-tracking branch 'upstream_jdk/pr/16606' into JDK-8319801
>> - Switch to CAS over LXSX
>> - Fix missing $
>> - Merge remote-tracking branch 'upstream_jdk/pr/16606' into JDK-8319801
>> - Merge remote-tracking branch 'upstream_jdk/pr/16606' into JDK-8319801
>> - Merge remote-tracking branch 'upstream_jdk/pr/16606' into JDK-8319801
>> - Merge remote-tracking branch 'upstream_jdk/pr/16606' into JDK-8319801
>> - Merge remote-tracking branch 'upstream_jdk/pr/16606' into JDK-8319801
>> - 8319801: Recursive lightweight locking: aarch64 implementation
>> - Cleanup: C2 fast_lock/fast_unlock aarch64
>
> src/hotspot/cpu/aarch64/c2_MacroAssembler_aarch64.cpp line 230:
>
>> 228: Register t2, Register t3) {
>> 229: assert(LockingMode == LM_LIGHTWEIGHT, "must be");
>> 230: // TODO: Current implementation does not use the box, consider removing.
>
> If it's not used, then please remove it? Maybe it can help to allocate one less register, which may be useful performance-wise when register pressure is high?
Done.
> src/hotspot/cpu/aarch64/c2_MacroAssembler_aarch64.cpp line 339:
>
>> 337: Register t2) {
>> 338: assert(LockingMode == LM_LIGHTWEIGHT, "must be");
>> 339: // TODO: Current implementation uses box only as a TEMP, consider renaming.
>
> Yeah, please rename the register.
Done.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/16608#discussion_r1464972254
PR Review Comment: https://git.openjdk.org/jdk/pull/16608#discussion_r1464972382
More information about the hotspot-dev
mailing list