RFR: 8332689: RISC-V: Use load instead of trampolines [v7]
Robbin Ehn
rehn at openjdk.org
Fri Jun 7 14:27:15 UTC 2024
On Thu, 6 Jun 2024 17:56:22 GMT, Hamlin Li <mli at openjdk.org> wrote:
>> Robbin Ehn has updated the pull request incrementally with one additional commit since the last revision:
>>
>> Remove tmp file
>
> src/hotspot/cpu/riscv/macroAssembler_riscv.hpp line 1571:
>
>> 1569: };
>> 1570:
>> 1571: enum NativeShortCall {
>
> Thanks for moving these into a separate name space, looks much better.
>
> Seems the naming convention of enum is with "_", not sure if we need to stick to it. NativeShortCall also looks good.
The common case should be e.g:
`enum RoundingMode `, `enum SizePolicyTrueValues`
But due to historical reason these NativeInst 'constants' use e.g.:
`enum Intel_specific_constants`
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/19453#discussion_r1631301509
More information about the hotspot-dev
mailing list