RFR: 8332689: RISC-V: Use load instead of trampolines [v18]
Robbin Ehn
rehn at openjdk.org
Wed Jun 26 09:09:15 UTC 2024
On Wed, 26 Jun 2024 08:26:28 GMT, Fei Yang <fyang at openjdk.org> wrote:
>> Robbin Ehn has updated the pull request with a new target base due to a merge or a rebase. The pull request now contains 26 commits:
>>
>> - Merge branch 'master' into 8332689
>> - Comments
>> - Missed in merge-fixes, minor revert
>> - Merge branch 'master' into 8332689
>> - Minor review comments
>> - Merge branch 'master' into 8332689
>> - To be pushed
>> - Merge branch 'master' into 8332689
>> - Review comments, removed dead code.
>> - Merge branch 'master' into 8332689
>> - ... and 16 more: https://git.openjdk.org/jdk/compare/25c3845b...78a240a9
>
> src/hotspot/cpu/riscv/macroAssembler_riscv.cpp line 4027:
>
>> 4025: }
>> 4026:
>> 4027: address MacroAssembler::load_call(Address entry) {
>
> How about rename this as something like `indirect_call`?
>
> BTW: I may need to take another look at the update of this PR. Hopefully, I can finish this week. Thank you for your patience.
The reason I don't like "indirect_call", is that all JALR jumps are indirect:
`The indirect jump instruction JALR (jump and link register)`
Maybe the middle ground: "indirect_load_call()" ?
I can live with indirect_call also, as it's indirect from programmers POV vs movptr + jalr.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/19453#discussion_r1654428332
More information about the hotspot-dev
mailing list