RFR: 8332689: RISC-V: Use load instead of trampolines [v18]
Fei Yang
fyang at openjdk.org
Thu Jun 27 08:32:41 UTC 2024
On Wed, 26 Jun 2024 09:06:38 GMT, Robbin Ehn <rehn at openjdk.org> wrote:
>> src/hotspot/cpu/riscv/macroAssembler_riscv.cpp line 4027:
>>
>>> 4025: }
>>> 4026:
>>> 4027: address MacroAssembler::load_call(Address entry) {
>>
>> How about rename this as something like `indirect_call`?
>>
>> BTW: I may need to take another look at the update of this PR. Hopefully, I can finish this week. Thank you for your patience.
>
> The reason I don't like "indirect_call", is that all JALR jumps are indirect:
> `The indirect jump instruction JALR (jump and link register)`
>
> Maybe the middle ground: "indirect_load_call()" ?
>
> I can live with indirect_call also, as it's indirect from programmers POV vs movptr + jalr.
Or `load_and_call`?
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/19453#discussion_r1656593099
More information about the hotspot-dev
mailing list