RFR: 8332900: RISC-V: refactor nativeInst_riscv.cpp and macroAssembler_riscv.cpp

Hamlin Li mli at openjdk.org
Wed May 29 15:55:15 UTC 2024


Hi,
Can you help to review the patch?
Currently, code in nativeInst_riscv.cpp and macroAssembler_riscv.cpp call each other, which is not right for readability and maintainance.
After refactoring, basically only code in nativeInst_riscv.cpp calls code in macroAssembler_riscv.cpp, but not in reverse direction. The only exception is code related to `membar` where code in macroAssembler_riscv.cpp still calls code nativeInst_riscv.cpp, I'm not sure whether it should be refactored too.

Thanks!

* Tests are still running, so far so good.

-------------

Commit messages:
 - move instruct checking
 - move instruction_size

Changes: https://git.openjdk.org/jdk/pull/19459/files
  Webrev: https://webrevs.openjdk.org/?repo=jdk&pr=19459&range=00
  Issue: https://bugs.openjdk.org/browse/JDK-8332900
  Stats: 697 lines in 6 files changed: 318 ins; 300 del; 79 mod
  Patch: https://git.openjdk.org/jdk/pull/19459.diff
  Fetch: git fetch https://git.openjdk.org/jdk.git pull/19459/head:pull/19459

PR: https://git.openjdk.org/jdk/pull/19459


More information about the hotspot-dev mailing list