RFR: 8332900: RISC-V: refactor nativeInst_riscv.cpp and macroAssembler_riscv.cpp [v3]

Fei Yang fyang at openjdk.org
Fri May 31 13:46:04 UTC 2024


On Wed, 29 May 2024 18:54:27 GMT, Hamlin Li <mli at openjdk.org> wrote:

>> Hi,
>> Can you help to review the patch?
>> Currently, code in nativeInst_riscv.cpp and macroAssembler_riscv.cpp call each other, which is not right for readability and maintainance.
>> After refactoring, basically only code in nativeInst_riscv.cpp calls code in macroAssembler_riscv.cpp, but not in reverse direction.
>> 
>> Thanks!
>> 
>> * Tests are still running, so far so good.
>
> Hamlin Li has updated the pull request incrementally with one additional commit since the last revision:
> 
>   restrict accessbility

LGTM modulo one minor comment. I think you are right in this refactoring work. Sorry for mis-understanding your opinion. Thanks!

src/hotspot/cpu/riscv/macroAssembler_riscv.hpp line 99:

> 97:   }
> 98: 
> 99:  private:

Maybe it's better to make those is_XXX functions public in case of future possible uses in other places?

-------------

PR Review: https://git.openjdk.org/jdk/pull/19459#pullrequestreview-2090850751
PR Review Comment: https://git.openjdk.org/jdk/pull/19459#discussion_r1622429210


More information about the hotspot-dev mailing list