RFR: 8346916: [REDO] align_up has potential overflow [v8]
Casper Norrbin
cnorrbin at openjdk.org
Wed Mar 5 21:33:55 UTC 2025
On Wed, 5 Mar 2025 19:45:52 GMT, Kim Barrett <kbarrett at openjdk.org> wrote:
>> Casper Norrbin has updated the pull request incrementally with one additional commit since the last revision:
>>
>> changed psoldgen check back to earlier version
>
> src/hotspot/share/runtime/globals.hpp line 1423:
>
>> 1421: product(size_t, MinHeapDeltaBytes, ScaleForWordSize(128*K), \
>> 1422: "The minimum change in heap space due to GC (in bytes)") \
>> 1423: range(0, max_uintx / 2 + 1) \
>
> Since the option type is `size_t` the range should have s/max_uintx/SIZE_MAX/.
> Though there are several other similar mismatches nearby. Perhaps leave tidying this
> up to a followup change?
Think it might be better to do them all at once in a followup. Right now, all `size_t` flags in the file use `max_uintx` for the max value instead of `SIZE_MAX`.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/23711#discussion_r1982213032
More information about the hotspot-dev
mailing list