RFR: 8356390: Rename ResolvedIndyEntry::set_flags to set_has_appendix [v2]
Johan Sjölen
jsjolen at openjdk.org
Fri May 9 11:55:50 UTC 2025
On Fri, 9 May 2025 11:39:52 GMT, Coleen Phillimore <coleenp at openjdk.org> wrote:
> While you're here, resolution_failed should have a named bit as well as has_appendix. I wonder if you can use C++ bit syntax too since SA doesn't read these flags.
As the interpreter reads the `_flag` through `flag_offset`, let's not do this.
-------------
PR Comment: https://git.openjdk.org/jdk/pull/25092#issuecomment-2866259090
More information about the hotspot-dev
mailing list