Request for review 7164144 (M)

Jon Masamitsu jon.masamitsu at oracle.com
Wed Apr 25 07:50:49 UTC 2012


Bengt,

Thanks for the review.

On 4/24/2012 11:54 PM, Bengt Rutisson wrote:
>
> Jon,
>
> Looks good to me too.
>
> Thanks for doing this refactoring!
>
> One question: I think hotspot normally does not use the "get_" prefix 
> for getters. Is it worth changing that too for the methods that you 
> are now renaming (e.g. FreeList::get_chunk_at_head(), 
> BinaryTreeDictionary<Chunk>::get_chunk_from_tree(), 
> FreeBlockDictionary::get_chunk()).

Hotspot doesn't use the "get_" on simple accessors (method that returns 
the value of a
field).  These methods do more.  For example get_chunk_from_tree() walks 
the
dictionary looking for a chunk of some size, removes the chunk and then
returns it.  So having the "get_" seems appropriate.

Jon

>
> I am perfectly fine with the change as it is now. Just thought I'd ask.
>
> Bengt
>
> On 2012-04-25 08:33, Srinivas Ramakrishna wrote:
>> Looks good to me, and sorry for the trouble this caused (mea 
>> culpa)... I hope you had an automatic refactoring feature in your IDE 
>> to make it a bit less painful
>> than manual modifications of so many names.
>>
>> -- ramki
>>
>> On Tue, Apr 24, 2012 at 11:09 PM, Jon Masamitsu 
>> <jon.masamitsu at oracle.com <mailto:jon.masamitsu at oracle.com>> wrote:
>>
>>     7164144: Fix variable naming style in freeBlockDictionary.* and
>>     binaryTreeDictionary*
>>
>>     The naming style in some CMS code is different from the
>>     the predominate style in hotspot.  Some of the CMS classes have
>>     recently been generalized for wider use.  This change normalizes
>>     the naming in those classes.
>>
>>     These changes are strictly name changes.
>>
>>     http://cr.openjdk.java.net/~jmasa/7164144/webrev.00/
>> <http://cr.openjdk.java.net/%7Ejmasa/7164144/webrev.00/>
>>
>>
>
>



More information about the hotspot-gc-dev mailing list