Request for review 7164144 (M)
Bengt Rutisson
bengt.rutisson at oracle.com
Wed Apr 25 06:54:15 UTC 2012
Jon,
Looks good to me too.
Thanks for doing this refactoring!
One question: I think hotspot normally does not use the "get_" prefix
for getters. Is it worth changing that too for the methods that you are
now renaming (e.g. FreeList::get_chunk_at_head(),
BinaryTreeDictionary<Chunk>::get_chunk_from_tree(),
FreeBlockDictionary::get_chunk()).
I am perfectly fine with the change as it is now. Just thought I'd ask.
Bengt
On 2012-04-25 08:33, Srinivas Ramakrishna wrote:
> Looks good to me, and sorry for the trouble this caused (mea culpa)...
> I hope you had an automatic refactoring feature in your IDE to make it
> a bit less painful
> than manual modifications of so many names.
>
> -- ramki
>
> On Tue, Apr 24, 2012 at 11:09 PM, Jon Masamitsu
> <jon.masamitsu at oracle.com <mailto:jon.masamitsu at oracle.com>> wrote:
>
> 7164144: Fix variable naming style in freeBlockDictionary.* and
> binaryTreeDictionary*
>
> The naming style in some CMS code is different from the
> the predominate style in hotspot. Some of the CMS classes have
> recently been generalized for wider use. This change normalizes
> the naming in those classes.
>
> These changes are strictly name changes.
>
> http://cr.openjdk.java.net/~jmasa/7164144/webrev.00/
> <http://cr.openjdk.java.net/%7Ejmasa/7164144/webrev.00/>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mail.openjdk.org/pipermail/hotspot-gc-dev/attachments/20120425/3f5042cb/attachment.htm>
More information about the hotspot-gc-dev
mailing list