Request for review: 8007762: Rename a bunch of methods in size policy across collectors
Tao Mao
tao.mao at oracle.com
Mon Feb 25 19:19:11 UTC 2013
8007762: Rename a bunch of methods in size policy across collectors
https://jbs.oracle.com/bugs/browse/JDK-8007762
webrev:
http://cr.openjdk.java.net/~tamao/8007762/webrev.01/
changeset:
The motivation of this change is associated with CR 7098155
(https://jbs.oracle.com/bugs/browse/JDK-7098155). For this, we need to
split compute_generations_free_space into two routines (one for
compute_eden_space_size and the other for compute_old_gen_free_space) in
order to save some overhead when we want to compute only one of the two
(JBS 8007763).
To unify the naming, a bunch of routines are renamed here.
(1) rename compute_generation_free_space() to
compute_generations_free_space() to reflect its complexity
(2) compute_*:
compute_survivor_space_size_and_threshold()
compute_generations_free_space() = compute_eden_space_size() +
compute_old_gen_free_space()
(3) resize_*_gen:
resize_young_gen()
resize_old_gen()
testing:
purely renaming; passed JPRT
More information about the hotspot-gc-dev
mailing list