Request for review: 8007762: Rename a bunch of methods in size policy across collectors

Jon Masamitsu jon.masamitsu at oracle.com
Mon Feb 18 15:46:07 UTC 2013


Tao,

Why this change from resize_old_gen() to
resize_tenured_gen()?  There are many
variable names and comments referring to
"old gen" still in ParallelScavengeHeap.

http://cr.openjdk.java.net/~tamao/8007762/webrev.00/src/share/vm/gc_implementation/parallelScavenge/parallelScavengeHeap.cpp.udiff.html

Jon

On 02/14/13 11:18, Tao Mao wrote:
> 8007762: Rename a bunch of methods in size policy across collectors
> https://jbs.oracle.com/bugs/browse/JDK-8007762
>
> webrev:
> http://cr.openjdk.java.net/~tamao/8007762/webrev.00/
>
> changeset:
> The motivation of this change is associated with CR 7098155 
> (https://jbs.oracle.com/bugs/browse/JDK-7098155). For this, we need to 
> split compute_generations_free_space into two routine (one for 
> compute_eden_space_size and the other for 
> compute_tenured_generation_free_space) in order to save some overhead 
> when we want to compute only one of the two. The next step is to split 
> PSAdaptiveSizePolicy::compute_generations_free_space(), which will be 
> resolved in CR 8007763.
>
> To unify the naming, a bunch of routines are renamed here.
> (1) compute_*:
>       compute_survivor_space_size_and_threshold()
>       compute_generations_free_space() = compute_eden_space_size() + 
> compute_tenured_generation_free_space()
> (2) resize_*_gen:
>       resize_young_gen()
>       resize_tenured_gen()
> (3) rename judging routine resize_geneneration() to need_resize() to 
> avoid ambiguity
>
> testing:
> purely renaming; passed JPRT
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mail.openjdk.org/pipermail/hotspot-gc-dev/attachments/20130218/a47d9543/attachment.htm>


More information about the hotspot-gc-dev mailing list