RFR (S): JDK-6991197 G1: specialize deal_with_reference() for narrowOop*
Stefan Karlsson
stefan.karlsson at oracle.com
Mon Jan 27 13:15:21 UTC 2014
Thomas,
On 2014-01-27 12:51, Thomas Schatzl wrote:
> Hi all,
>
> can I have your opinion and optionally a review for the following
> small change? Like the bug title reads, the change manually specializes
> G1ParScanThreadState::deal_with_reference() for the narrowOop*, allowing
> some additional specialization.
>
> Measurements indicate a small improvement (~1%) on object copy time for
> specjbb, however not significant.
>
> As I have the change on hand (I had to do it anyway for measurements) I
> would like to ask your opinion whether to keep it or not. If so, ask for
> review.
>
> I am actually undecided - personally I tend to like it (as it trims fat)
> and it seems small enough to keep it and does not distract too much, but
> it does not really show up on measurements.
>
> Testing:
> jprt, specjbb2005/13, specjvm98/2008, CRM Fuse
>
> Bug entry:
> https://bugs.openjdk.java.net/browse/JDK-6991197
>
> Webrev:
> http://cr.openjdk.java.net/~tschatzl/6991197/webrev/
Have you considered specializing has_partial_array_mask() to always
return false when T = narrowOop? If you do it that way, you would get
rid of the code duplication.
thanks,
StefanK
>
> Thanks,
> Thomas
>
More information about the hotspot-gc-dev
mailing list