RFR: 8076265: Simplify deal_with_reference
Kim Barrett
kim.barrett at oracle.com
Tue Mar 31 19:41:36 UTC 2015
Please review this simplification and cleanup of CMTask::deal_with_reference.
I will need a sponsor for this change.
Removed _CHECK_BOTH_FINGERS_ macro, changing the code to assume it was
true (as it always has been since it was introduced), eliminating some
duplicated code.
Simplfied the current region tests, making use of all the associated
variables either being set or NULL together, so no need for multiple
NULL checks.
Added a helper function for logging and pushing objects on the mark
stack, removing some (almost) code duplication. This is also the
place where some forthcoming changes for 8069367 will end up.
CR:
https://bugs.openjdk.java.net/browse/JDK-8076265
Webrev:
http://cr.openjdk.java.net/~kbarrett/8076265/webrev/
Testing:
JPRT
local RefWorkload with -XX:+UseG1GC
local JTREG with -XX:+UseG1GC
More information about the hotspot-gc-dev
mailing list