Request for review JDK-8165674 - G1CMMarkStack::out_of_memory possibly redundant
alexander.harlap at oracle.com
Tue Mar 7 20:46:15 UTC 2017
"Mark stack should be empty (unless it has overflown)"
On 3/7/2017 3:05 PM, Kim Barrett wrote:
>> On Mar 7, 2017, at 2:26 PM, Alexander Harlap <alexander.harlap at oracle.com> wrote:
>> Happy to get review.
>> Changed to use
> I like this better. I'd intended to make comments similar promises but he got there first.
>> Revised change is here:
> One very minor and nit:
> 1746 "Mark stack should be empty (unless it is out of memory)");
> The assert message should refer to “overflow" rather than "out of memory”
> Looks good otherwise.
> I don't need a new webrev for a change there.
More information about the hotspot-gc-dev