RFR (S): 8193312: Rename VM_CGC_Operation to VM_G1ConcurrentGCOperation

Per Liden per.liden at oracle.com
Tue Dec 4 20:38:25 UTC 2018


Hi Thomas,

On 2018-12-04 17:39, Thomas Schatzl wrote:
> Hi all,
> 
>    can I have reviews for this renaming of the VM operation classes in
> G1 to something a bit more like the remaining code.
> 
> I kept the VM_ prefix only for continuity with the parent class.
> 
> CR:
> https://bugs.openjdk.java.net/browse/JDK-8193312
> Webrev:
> http://cr.openjdk.java.net/~tschatzl/8193312/webrev/

There seems to be a naming mismatch, where you have

  +  template(G1ConcurrentOperation)                 \

and then

  +class VM_G1ConcurrentGCOperation : public VM_Operation {

I.e. "G1ConcurrentGCOperation" vs "G1ConcurrentOperation".

Looking at the list of other registered G1 operations, they are:

    template(G1CollectForAllocation)                \
    template(G1CollectFull)                         \

Just a suggestion, but I would leave out "GC" and "Operation", as the 
other G1 ops doesn't use that in their name, and just call it 
"G1Concurrent".

cheers,
Per

> Testing:
> compilation on all platforms
> 
> Thanks,
>    Thomas
> 
> 



More information about the hotspot-gc-dev mailing list