RFR: 8211446: Replace oop_pc_follow_contents with oop_iterate and closure
Stefan Johansson
stefan.johansson at oracle.com
Mon Oct 8 14:02:24 UTC 2018
Hi Leo,
On 2018-10-04 18:27, Leo Korinth wrote:
> Hi!
>
> This is the is the second enhancement in a series of three to remove
> Parallel GC specific behaviour from shared code. I will post all three
> enhancements to the mailing list.
>
> For a description on what is changed see my earlier "RFR: 8201436:
> Replace oop_ps_push_contents with oop_iterate and closure"
>
> Enhancement:
> https://bugs.openjdk.java.net/browse/JDK-8211446
>
> Webrev:
> http://cr.openjdk.java.net/~lkorinth/8211446/00/
The change looks good in general but the closures here should not be
prefixed with PS but rather PC, since they are used by the parallel
compact algorithm.
Some additional comments:
src/hotspot/share/gc/parallel/psCompactionManager.inline.hpp
The new versions of follow_class_loader and follow_contents have been
moved to the end of the file, is there any reason for that otherwise I
would like them to be in the old location right with the other
follow_*-functions.
Also the indentation of the closures should be fixed, use 2 space
instead of 4.
---
src/hotspot/share/gc/parallel/psParallelCompact.cpp
PSReferenceProcessor should be called PCReferenceProcessor and I also
think you should remove the default value in the constructor.
---
Thanks,
Stefan
>
> Testing:
> - all patches build on linux after the latest rebase.
> - mach5 (linux, windows and mac) tier1,tier2,tier3,tier4,tier5 has
> passed with all three patches applied
> - aurora tests have been run and seem to indicate no change in general
> on this webrev in the patch series.
>
> Thanks, Leo
More information about the hotspot-gc-dev
mailing list