RFR: 8252221: Use multiple workers for Parallel GC pre-touching

Thomas Schatzl thomas.schatzl at oracle.com
Fri Oct 9 13:25:39 UTC 2020


Hi again,

   some more nits:

- the code does not compiler without precompiled headers because of 
undeclared WorkGang.

hotspot/share/gc/parallel/mutableSpace.hpp:90:27: error: 'WorkGang' has 
not been declared
[2020-10-09T11:44:35,851Z]    90 |                           WorkGang* 
pretouch_gang = NULL);
[2020-10-09T11:44:35,851Z]       |                           ^~~~~~~~

Please fix and check by building with --disable-precompiled_headers 
configure parameters.

Same in mutableNUMASpace.hpp.

The cpp files also need the workgroup.hpp include.

- please rename pretouch.hpp to pretouchTask.hpp.

- includes are completely missing in pretouch.hpp. Needs at least 
workgroup.hpp, globals.hpp (for the UseTransparentHugePages global), 
atomic.hpp, os.hpp

- please move the implementation of the various methods of PretouchTask 
into a .cpp file. Try to avoid includes in the .hpp file.

Thanks,
   Thomas

On 09.10.20 12:53, Thomas Schatzl wrote:
> Hi Amit,
> 
> On 06.10.20 20:14, Amit Pawar wrote:
>> On Mon, 28 Sep 2020 04:11:16 GMT, Amit Pawar 
>> <github.com+71302734+amitdpawar at openjdk.org> wrote:
>>
>>> Thanks for agreeing and will update the PR with suggested changes for 
>>> final review.
>>>
>>> Thanks,
>>> Amit
>>
>> Hi Thomas,
>>
>> PR is updated with suggested changes. Please review.
>>
>> Thanks,
>> Amit
> 
> 
>    looks really good now, some minor nits:
> 
> - g1PageBasedVirtualSpace.cpp/mutableSpace.cpp: please keep the include 
> declarations sorted
> 
> - mutableSpace.cpp:118+
> 
>   PretouchTask::pretouch("ParallelGC PreTouch", (char*)head.start(),
>                          (char*)head.end(), page_size, pretouch_gang);
> 
>   PretouchTask::pretouch("ParallelGC PreTouch", (char*)tail.start(),
>                          (char*)tail.end(), page_size, pretouch_gang);
> 
>   - Please move the end_address parameter to the previous line even if 
> it crosses 80 chars.
>   - the two tasks could be named differently, i.e. "ParallelGC PreTouch 
> head" and "... tail"
> 
> - pretouch.hpp: s/2018/2020 in the header; maybe update the end dates of 
> the other files too.
> 
> I'll let it pass through testing over the weekend. I will report back if 
> there is anything problematic.
> 
> Thanks,
>    Thomas




More information about the hotspot-gc-dev mailing list