RFR: 8272609: Add string deduplication support to SerialGC [v10]
Albert Mingkun Yang
ayang at openjdk.java.net
Sat Aug 21 20:16:30 UTC 2021
On Sat, 21 Aug 2021 19:09:35 GMT, Kim Barrett <kbarrett at openjdk.org> wrote:
>> I believe it's desirable to narrow the request window (btw first `add` and `flush`), which offers more prompt string-dedup and memory release (in `flush`). Additionally, it makes more sense to call `flush` right after the complete live objects traversal (strong-marking + final-marking as part of ref-processing), since we will not visit any new objects then.
>
> I prefer it where it is. Rather than putting something between phantom
> reference processing an oopstorage-based weak processing, I would prefer to
> merge those two. I don't remember if there's an RFE for that.
I still think `flush` should be called sooner, e.g. inside `mark_sweep_phase1`, which is not in conflict with merging phantom-processing and weak root processing. Anyway, this is subjective; feel free to integrate the current version.
-------------
PR: https://git.openjdk.java.net/jdk/pull/5153
More information about the hotspot-gc-dev
mailing list