RFR: 8319373: Serial: Refactor dirty cards scanning during Young GC [v10]

Albert Mingkun Yang ayang at openjdk.org
Mon Nov 20 20:35:50 UTC 2023


On Mon, 20 Nov 2023 19:27:50 GMT, Kim Barrett <kbarrett at openjdk.org> wrote:

>> Albert Mingkun Yang has updated the pull request incrementally with one additional commit since the last revision:
>> 
>>   review
>
> src/hotspot/share/gc/serial/cardTableRS.cpp line 351:
> 
>> 349: CardTable::CardValue* CardTableRS::find_first_dirty_card(CardValue* const start_card,
>> 350:                                                          CardValue* const end_card) {
>> 351:   using Word = uintptr_t;
> 
> I think it would be better if Word was consistent with clean_card_row_val, to eliminate casts now and in
> the future when you address my earlier comment about needing a clean-row accessor.  So I suggest
> `using Word = decltype(clean_card_row_val());`.
> Maybe as part of the clean-row accessor also add a CardRow type alias.
> Note that I think that type should be unsigned (as currently here, e.g. uintptr_t) rather than signed
> (as currently provided by clean_card_row_val).

The similar card-scanning code in g1remset also defines `Word`. I will extract them together. This PR targets Serial-specific issue, so I wanna minimize touching the shared code, e.g. introducing a new `CardWord` type and operations around it.

> src/hotspot/share/gc/serial/cardTableRS.cpp line 356:
> 
>> 354:   constexpr Word clean_word = (Word)CardTable::clean_card_row_val();
>> 355: 
>> 356:   CardValue* i_card = start_card;
> 
> What does the "i_" prefix here mean?  Something like "cur_card" might be a better name.

It's for "iterator".

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/16492#discussion_r1399717744
PR Review Comment: https://git.openjdk.org/jdk/pull/16492#discussion_r1399717186


More information about the hotspot-gc-dev mailing list