RFR: 8319373: Serial: Refactor dirty cards scanning during Young GC [v10]

Kim Barrett kbarrett at openjdk.org
Tue Nov 21 07:56:16 UTC 2023


On Mon, 20 Nov 2023 20:30:02 GMT, Albert Mingkun Yang <ayang at openjdk.org> wrote:

>> src/hotspot/share/gc/serial/cardTableRS.cpp line 356:
>> 
>>> 354:   constexpr Word clean_word = (Word)CardTable::clean_card_row_val();
>>> 355: 
>>> 356:   CardValue* i_card = start_card;
>> 
>> What does the "i_" prefix here mean?  Something like "cur_card" might be a better name.
>
> It's for "iterator".

I don't think I would have ever guessed that, which suggests it might not be an ideal naming choice.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/16492#discussion_r1400148691


More information about the hotspot-gc-dev mailing list