RFR: 8328792: Parallel: Refactor PSParallelCompact::summary_phase [v9]
Albert Mingkun Yang
ayang at openjdk.org
Wed Apr 10 14:30:10 UTC 2024
On Wed, 10 Apr 2024 14:14:09 GMT, Ivan Walulya <iwalulya at openjdk.org> wrote:
>> Albert Mingkun Yang has updated the pull request with a new target base due to a merge or a rebase. The pull request now contains one commit:
>>
>> pgc-compute-dense-prefix
>
> src/hotspot/share/gc/parallel/psParallelCompact.cpp line 1143:
>
>> 1141:
>> 1142: if (maximum_compaction || is_old_gen_overflowing || is_interval_ended || is_region_full) {
>> 1143: _maximum_compaction_gc_num = total_invocations;
>
> Based on the function name, we don't expect it to do more than `reassess_maximum_compaction`, additionally this modification also requires that we call `reassess_maximum_compaction` even when `maximum_compaction` is already true. Is is possible to decouple these two: `reassess_maximum_compaction` and `_maximum_compaction_gc_num = total_invocations`?
`_maximum_compaction_gc_num` is on the same abstraction level as the checking denoted as "JVM flags". Separating them will probably make code harder to follow.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/18451#discussion_r1559549567
More information about the hotspot-gc-dev
mailing list