RFR: 8322296: Introduce CardWord for word iteration on CardTable [v3]
Albert Mingkun Yang
ayang at openjdk.org
Tue Jan 2 09:27:08 UTC 2024
On Thu, 28 Dec 2023 13:20:39 GMT, Guoxiong Li <gli at openjdk.org> wrote:
>> src/hotspot/share/gc/shared/cardTable.hpp line 94:
>>
>>> 92: virtual ~CardTable() = default;
>>> 93:
>>> 94: static bool is_word_aligned(const CardValue* const card) {
>>
>> Maybe is_word_aligned => is_card_word_aligned? The existing name seems overly generic, and has other
>> (semantic, though probably not operational) meanings elsewhere.
>
> There is a similar method named `is_card_aligned`. So the `is_card_word_aligned` seems more consistent and better.
It can be misinterpreted as "is this card word-aligned". In fact, this method doesn't care about "Card". Maybe calling the type "Word"? It's not really related to "Card" -- it just lives inside this class.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/17144#discussion_r1439271164
More information about the hotspot-gc-dev
mailing list